AWS Related Broker Outage

Incident Report for Option Alpha

Resolved

Outage seems to be resolved. No issues persisted during the afternoon trading session.
Posted Oct 20, 2025 - 19:10 EDT

Monitoring

Many traders are successfully placing live trades via TradeStation and we'll continue closely monitoring.
Posted Oct 20, 2025 - 12:06 EDT

Update

We are continuing to monitor the outages.
Posted Oct 20, 2025 - 09:57 EDT

Identified

Amazon Web Services (AWS) is currently experiencing an ongoing outage in the US-East-1 region that is impacting multiple broker related services for trading including TradeStation. If needed, please monitor your positions with your broker directly if possible. OA itself is fully operational at this time.
Posted Oct 20, 2025 - 09:51 EDT
This incident affected: Brokers (TradeStation, Charles Schwab).